All systems have been performing normally for the last 2 hours, so we are now considering this issue resolved. We will continue to monitor closely. A post mortem will also be provided to affected customers as soon as we complete our investigation of the incident.
Posted Apr 11, 2016 - 18:08 EDT
Monitoring
The upstream provider has resolved the issue with their infrastructure and the network has returned to stable operation. We will continue to monitor the situation. In the mean time, if you are still unable to access your control panel please give it about 5 minutes and try again.
Posted Apr 11, 2016 - 15:55 EDT
Identified
We have identified the problem is with an upstream provider and they are working on a resolution.
Posted Apr 11, 2016 - 11:41 EDT
Investigating
We are investigating a network outage at our London data center. Customers with their control panel hosted in this region will be unable to access their account at this time. However, ad server has been failed over to our Vancouver data while we continue to troubleshoot.